来自 澳门新葡亰官网 2019-11-12 13:32 的文章
当前位置: 澳门新葡亰app > 澳门新葡亰官网 > 正文

澳门新葡亰app原先的版本已经不帮衬了,然后更

按照网上的命令都为安装php5-fpm 和 php5-sqlite, 但是发现无法找到软件,可能是系统版本比较高的缘故,原来的版本已经不支持了。

安装Ubuntu Server 16.04.1 LTS

经过努力华找到如下安装方法
sudo apt-get install php-fpm (默认安装的是php7)
sudo apt-get install php7.0-sqlite3

更新安装包目录 sudo apt-get update

需要的朋友可以试一下

更新已安装的应用 sudo apt-get upgrade

安装apache

sudo apt-get install apache2

安装php5.6

由于Ubuntu16.04.1默认获取的php版本是php7.0,因此需要其他目录源

sudo apt-get install software-properties-common

sudo add-apt-repository ppa:ondrej/php

然后更新及安装php

sudo apt-get update

sudo apt-get install php5.6

(如果已安装其他版本,需先卸载然后安装,参看 )

安装mysql

sudo apt-get install mysql-server

其他模板安装

sudo apt-get install libapache2-mod-php5.6

sudo apt-get install php5.6-mysql

sudo apt-get install php5.6-gd

基本配置完成

另:改变apache默认访问目录

默认访问目录为/var/www/html

修改为/var/www

sudo nano /etc/apache2/sites-enabled/000-default    在文档中找到 DocumentRoot 在后面修改要放置网页文件的目录(/var/www)

重启apache

sudo /etc/init.d/apache2 restart

本文由澳门新葡亰app发布于澳门新葡亰官网,转载请注明出处:澳门新葡亰app原先的版本已经不帮衬了,然后更

关键词: